最新消息:

慧股时空网盘点同花顺MACD缠论指标公式

配资头条 admin 20浏览 0评论

导读:慧股时空网盘点同花顺MACD缠论指标公式

慧股时空网盘点同花顺MACD缠论指标公式

SHORT:=12;LONG:=26;M:=9;DIFF:=(ema(close,SHORT) – emA(CLOSE,LONG));dea:=EMA(DIFF,M);macD2:=(2 * (DIFF – DEA));DU0:=croSS(DIFF,0);UD0:=CROSS(0,DIFF);tdU0:=BARSLAst(DU0);TUD0:=BARSlast(UD0);DU3:=REF(DU0,1);UD3:=REF(UD0,1);TDU3:=BARSLAST(DU3);TUD3:=BARSLAST(UD3);UDGline:=IF((TDU3 < TUD3),REF(HHV(high,2),TDU3),REF(Llv(LOW,2),TUD3));JDU0:=(((REF(CLOSE,1) UDGLINE)) AND (TDU0 = REF(UDGLINE,1)) AND (CLOSE < UDGLINE)) AND (TUD0 < TDU0));JDU1:=(JDU0 AND (COUNT(JDU0,TDU0) = 1));JUd1:=(JUD0 AND (COUNT(JUD0,TUD0) = 1));JDU2:=(JDU1 AND (REF(BARSLAST(JUD1),1) REF(BARSLAST(JDU1),1)));JDU3:=(JDU1 AND (REF(BARSLAST(JUD1),1) > REF(BARSLAST(JDU1),1)));JUD3:=(JUD1 AND (REF(BARSLAST(JUD1),1) < REF(BARSLAST(JDU1),1)));BSLINE:=IF((BARSLAST(JDU2) BARSLAST(JUD1))),MAX(HHV(DIFF,0),HHV(MACD2,0)),(JUD1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))),MAX(HHV(DIFF,0),HHV(MACD2,0)),0),CIRCledOT,colorred;DRAWLINE((JUD1 OR (BARSLAST(JDU1) BARSLAST(JUD1))),MIN(LLV(DIFF,0),LLV(MACD2,0)),0),CIRCLEDOT,colorgreen;STICKLINE((MACD2 >= 0),0,MACD2,1,1),colorred;STICKLINE(((MACD2 >= 0) AND (MACD2 < REF(MACD2,1))),0,MACD2,1,0),colorred;stiCKLINE((MACD2 < 0),0,MACD2,1,0),COLORFFFF00;STICKLINE(((MACD2 REF(MACD2,1))),0,MACD2,1,1),COLORFFFF00;DIF:DIFF,colorwhite;MACD:DEA,coloryellow;DEF:MACD2,LINethICK0,COLORFFFF00;STICKLINE((CLOSE > 0),0,0,10,0),COLOR808080;DEFUT:=BARSLAST(CROSS(MACD2,0));DEfdT:=BARSLAST(CROSS(0,MACD2));DEFUL:=IF((MACD2 >= 0),HHV(MACD2,(DEFUT 1)),REF(HHV(MACD2,(DEFUT 1)),(DEFDT 1)));DEFDL:=IF((MACD2 0) AND (MACD2 REF(MACD2,2))) AND (REF(MACD2,2) > REF(MACD2,3))),MACD2,2);DRAWicoN(((((HHV(MACD2,4) REF(MACD2,1))) AND (REF(MACD2,1) < REF(MACD2,2))) AND (REF(MACD2,2) BARSLAST(JUD1))) AND (MACD2 >= 0)) AND (REF(MACD2,1) DEFU2L)),MACD2,DRAWNULL),CIRCLEDOT,coloryellow;IF(((((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))) AND (MACD2 REF(DEFD2L,1))) AND (MACD2 < DEFD2L)),MACD2,DRAWNULL),CIRCLEDOT,coloryellow;低位金叉:CROSS(DIFF,DEA) AND DIFF=0));二次金叉:CROSS(DIFF,DEA) AND DEACLOSE AND DIFF>REF(DIFF,A1 1) AND CROSS(DIFF,DEA);STICKLINE(底背离,0,0.01,6,0),COLOR00FF00;底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,LINETHICK2;DRAWTEXT(底背离,0.015,’A’),COLORFF00FF;A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));顶背离:=REF(CLOSE,A2 1)DIFF AND CROSS(DEA,DIFF);顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,LINETHICK2;DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.05,’全’),COLOR0000FF,LINETHICK2;R1:=EMA(HHV(HIGH,500),21);r2:=EMA(HHV(HIGH,250),21);R3:=EMA(HHV(HIGH,90),21);R4:=EMA(LLV(LOW,500),21);R5:=EMA(LLV(LOW,250),21);R6:=EMA(LLV(LOW,90),21);

价值投资究竟是什么?它应该购买濒临破产的低价股,还是购买气势如虹的蓝筹股?从格雷厄姆开始,产生了许多价值投资的分支流派,成功的基金经理人拥有独特的模型和选股方法,但是其核心仍然与格雷厄姆差别不大。

转载请注明:开心滔滔 » 慧股时空网盘点同花顺MACD缠论指标公式

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址